Bei Fragen:
support@billbee.io

Neues Thema starten

Bestellungen per E-Mail einlesen zu lassen

 Hallo Community,


ich habe gelesen das ich einen manuellen Shop anlegen kann dieser soll dann Bestellungen per E-mail einlesen. Leider komme ich jetzt hier nicht weiter.

Habe ich das falsch verstanden, mein Gedanke war jetzt, ich habe ein Postfach wo BillBee Bestellungen einliest.


Unter dem Hilfelink finde ich leider nichts passendes.

https://support.billbee.io/support/solutions/folders/5000284465



Vielen Dank für eine Rückmeldung

Franz


Hallo Franz, 


hast du da schon eine Antwort drauf bekommen?


Viele Grüße Katja

Hallo ihr Beiden,


es gibt einen Mailimport, aber kein Billbee Postfach.

Ihr müsst die Mails in einer bestimmten Form formatieren, sodass sie als Bestellungen eingelesen werden können.

Wie könnt ihr hier nachlesen:

https://support.billbee.io/support/solutions/articles/5000748837-feldbeschreibung-json-e-mail-import

Kann ich das mit einem Formular erstellen? Also z.b. aus Wordpress heraus. Dort bestellen meine Kunden über ein Formular, welches automatisch eine Email an mich sendet auf Wunsch auch mit einer CSV Datei.

Hallo Community, ich habe mein JSON an die genannte Mail gesende, jedoch kam nichts an.


....

Billbee kann Bestellungen per E-Mail einlesen, welche als Body-Text ein JSON mit festgelegtem Aufbau beinhalten.

Dieses JSON muss an SHOP_ID-json-orderimport@inbound.billbee.de gesendet werden.


Das JSON Dokument muss den folgenden Aufbau haben. Ein Beispiel JSON kannst du unten bei den Anhängen herunterladen.

....


Welche ShopID muss ich hier denn eintragen ? 

SHOP_ID-json-orderimport@inbound.billbee.de


Wo kann man Fehler auslesen oder prüfen was schief gelaufen ist ? 


Viele Grüße

Kai

Hallo Kai,


dafür musst du einen manuellen Shop anlegen, und dann findest du die Shop ID in der URL :) 

Hallo zusammen,

ich versuche mich auch gerade an dem Bestellimport per EMail.
Ich habe  es mit meiner Shop-ID und der Test-JSON Datei probiert, aber die Bestellung wird nicht eingelesen. Die Mail mit dem JSON als Body wird allerdings an mein Postfach weitergeleitet.

Gibt es irgendwo Error-Logs, um herauszufinden, was schiefgelaufen ist?

Viele Grüße

Susanne

Wie sieht dein JSON den aus ?  Einen log habe ich noch nicht entdeckt. Hatte das selbe Problem auch als ich bei den ITem Kosten ein Komma statt einem Punkt verwendet hatte. Alle anderen nicht Optionalen Informationen hast du im JSON ?. Gruß Kai

Ich habe die Beispiel-Datei genommen, die unten auf dieser Seite verlinkt ist und bin davon ausgegangen, dass sie valide ist:

https://support.billbee.io/support/solutions/articles/5000748837-feldbeschreibung-json-e-mail-import

Gruß Susanne


Ich bin mir nicht sicher ob vor oder nach der JSON definition Zeichen sein dürfen. Wäre interessant. 


Versuche doch mal ein Abgespecktes JSON mit den nur "muss" Feldern, beim order_item noch Anpassungen entsprechend deiner Billbee Produkte mache, sonst legst du neue Produkte and oder sie werden nicht auf bereits angelegte gemappt.


{

    "order_id": "XXXTestXXX",

    "currency_code": "EUR",    

 "order_date": "2020-05-10T07:13:00",

    "invoice": {

        "salutation": 1,

        "firstname": "Max.",

        "lastname": "Meier",

        "address_1": "Musterstraße 3",

        "zip": "97237",

        "city": "Musterdorf",

        "country": "DE",

        "company": "Muster GmbH"

    },

    "shipping": {

        "salutation": 0,

        "firstname": "Max",

        "lastname": " Meier",

        "address_1": "Musterstraße 11",

        "zip": "09211",

        "city": "Musterstadt",

        "country": "DE",

        "company": "Muster GmbH"

    },

    "order_status_id": 2,

    "comment": "test",

    "order_items": [

        {

            "quantity": 1,

            "totalprice": 100.00  ,

            "product_id": Meine ProduktID für diesen manuellen Shop,

            "name": "Mein Produktname",

            "sku": "Die SKU über die der Artikel zu meinen Billbee Artikeln gemappt werden soll",

        }

    ],

    "tags": [

        "test"

    ] 

Danke für den Hinweis, ich habe jetzt nur die Pflichtfelder übermittelt und nun funktioniert es.

Allerdings weiß ich dadurch noch nicht, welche Felder Probleme gemacht haben. Schade, dass es offenbar kein Log gibt, probieren ist ja auch keine Lösung.

Ich werde mich mal mit der API auseinandersetzen.

Gruß

Susanne

Anmelden um einen Kommentar zu veröffentlichen