Neues Thema starten

Woocommerce - Bestellungen Abgleich geht nicht zurück an Woocommerce

Ich habe seit ein paar Tagen das Problem, dass der Import in Billbee zwar funktioniert, aber Woocommerce nicht den Status "Versendet" erhält und folglich die Bestellungen noch als offen dort stehen und keine Mail an den Kunden raus geht.


Ich habe schon eine neue API KEYS eingestellt, REST API ist aktiviert.

Habe den Screenshot für die erweiterten Einstellungen angehängt


Freue mich über jeden Tipp.


lg Jonas


Hi ihr beiden, 


also da scheint irgendeine Abfrage blockiert zu werden, schreibt uns gern mal ein Ticket dazu, dann rufen wir den Shop ab und schauen, wo das Problem liegt :) 

Hi,


Leider bin ich in Sachen .htaccess auch kein Experte. Die Firewall würde ich auch lieber wieder einschalten.


Ich hatte bis gerade das gleiche Problem. Ich habe mit POSTMAN manuell Versuche gemacht. Die WooCommerce API benutzt eingentlich PUT für die Updates.


Mit POSTMAN hatte ich gemerkt, dass PUT mit Error 403 quittiert wurde auf unserem Webserver.

Das PUT konnte ich wieder zum Laufen bringen mit dieser Änderung.


Ob es das Problem jetzt endgültig gelöst hat weiß ich noch nicht gerade.


Ich habe das "put" aus der Einschränkung hier genommen:


# 6G:[REQUEST METHOD]
<IfModule mod_rewrite.c>
#ALT:    RewriteCond %{REQUEST_METHOD} ^(connect|debug|move|put|trace|track) [NC]
    RewriteCond %{REQUEST_METHOD} ^(connect|debug|move|trace|track) [NC]
    RewriteRule .* - [F]
</IfModule>


Also ich hatte das identische Problem. Bei uns war die 6G-Firewall in der .htaccess. Diese verhindert wohl die Veränderung des Status von Billbee zu Woocommerce. Ist natürlich blöd, dass man das deaktivieren muss. Vielleicht weiß ja ein Experte, welche Einstellung genau den Zugriff verhindert?


 

 

# 6G FIREWALL/BLACKLIST - 2019
# @ https://perishablepress.com/6g/

# 6G:[QUERY STRINGS]
<IfModule mod_rewrite.c>
	RewriteEngine On
	RewriteCond %{QUERY_STRING} (eval\() [NC,OR]
	RewriteCond %{QUERY_STRING} (127\.0\.0\.1) [NC,OR]
	RewriteCond %{QUERY_STRING} ([a-z0-9]{2000,}) [NC,OR]
	RewriteCond %{QUERY_STRING} (javascript:)(.*)(;) [NC,OR]
	RewriteCond %{QUERY_STRING} (base64_encode)(.*)(\() [NC,OR]
	RewriteCond %{QUERY_STRING} (GLOBALS|REQUEST)(=|\[|%) [NC,OR]
	RewriteCond %{QUERY_STRING} (<|%3C)(.*)script(.*)(>|%3) [NC,OR]
	RewriteCond %{QUERY_STRING} (\\|\.\.\.|\.\./|~|`|<|>|\|) [NC,OR]
	RewriteCond %{QUERY_STRING} (boot\.ini|etc/passwd|self/environ) [NC,OR]
	RewriteCond %{QUERY_STRING} (thumbs?(_editor|open)?|tim(thumb)?)\.php [NC,OR]
	RewriteCond %{QUERY_STRING} (\'|\")(.*)(drop|insert|md5|select|union) [NC]
	RewriteRule .* - [F]
</IfModule>

# 6G:[REQUEST METHOD]
<IfModule mod_rewrite.c>
	RewriteCond %{REQUEST_METHOD} ^(connect|debug|move|put|trace|track) [NC]
	RewriteRule .* - [F]
</IfModule>

# 6G:[REFERRERS]
<IfModule mod_rewrite.c>
	RewriteCond %{HTTP_REFERER} ([a-z0-9]{2000,}) [NC,OR]
	RewriteCond %{HTTP_REFERER} (semalt.com|todaperfeita) [NC]
	RewriteRule .* - [F]
</IfModule>

# 6G:[REQUEST STRINGS]
<IfModule mod_alias.c>
	RedirectMatch 403 (?i)([a-z0-9]{2000,})
	RedirectMatch 403 (?i)(https?|ftp|php):/
	RedirectMatch 403 (?i)(base64_encode)(.*)(\()
	RedirectMatch 403 (?i)(=\\\'|=\\%27|/\\\'/?)\.
	RedirectMatch 403 (?i)/(\$(\&)?|\*|\"|\.|,|&|&amp;?)/?$
	RedirectMatch 403 (?i)(\{0\}|\(/\(|\.\.\.|\+\+\+|\\\"\\\")
	RedirectMatch 403 (?i)(~|`|<|>|:|;|,|%|\\|\{|\}|\[|\]|\|)
	RedirectMatch 403 (?i)/(=|\$&|_mm|cgi-|muieblack)
	RedirectMatch 403 (?i)(&pws=0|_vti_|\(null\)|\{\$itemURL\}|echo(.*)kae|etc/passwd|eval\(|self/environ)
	RedirectMatch 403 (?i)\.(aspx?|bash|bak?|cfg|cgi|dll|exe|git|hg|ini|jsp|log|mdb|out|sql|svn|swp|tar|rar|rdf)$
	RedirectMatch 403 (?i)/(^$|(wp-)?config|mobiquo|phpinfo|shell|sqlpatch|thumb|thumb_editor|thumbopen|timthumb|webshell)\.php
</IfModule>

# 6G:[USER AGENTS]
<IfModule mod_setenvif.c>
	SetEnvIfNoCase User-Agent ([a-z0-9]{2000,}) bad_bot
	SetEnvIfNoCase User-Agent (archive.org|binlar|casper|checkpriv|choppy|clshttp|cmsworld|diavol|dotbot|extract|feedfinder|flicky|g00g1e|harvest|heritrix|httrack|kmccrew|loader|miner|nikto|nutch|planetwork|postrank|purebot|pycurl|python|seekerspider|siclab|skygrid|sqlmap|sucker|turnit|vikspider|winhttp|xxxyy|youda|zmeu|zune) bad_bot
	
	# Apache < 2.3
	<IfModule !mod_authz_core.c>
		Order Allow,Deny
		Allow from all
		Deny from env=bad_bot
	</IfModule>

	# Apache >= 2.3
	<IfModule mod_authz_core.c>
		<RequireAll>
			Require all Granted
			Require not env bad_bot
		</RequireAll>
	</IfModule>
</IfModule>

# 6G:[BAD IPS]
<Limit GET HEAD OPTIONS POST PUT>
	Order Allow,Deny
	Allow from All
	# uncomment/edit/repeat next line to block IPs
	# Deny from 123.456.789
</Limit>

 

 

Habe mir mal unsere htaccess angesehen, da gibt es keine Sicherheitseinstellungen - nur Anweisungen für das Caching. Muss in Billbee evtl. noch eine regel generiert werden, die den Abgleich zum Shop auslöst?

 

habe ebenfalls dasselbe Problem. Könnte jemand mitteilen, welche Änderungen in der htcaccess vorgenommen worden sind?

Danke


3 Personen gefällt dies
Ich habe genau das gleiche Problem. Welche Sicherheitseinstellungen habt ihr in der htaccess geändert?

 


4 Personen gefällt dies

Super, danke dir Jonas!

Das hat auch bei uns geholfen. 


Grüße,

Philipp

Hi Phillip, bei uns lag es an einer Sicherheitseinstellung in der HTACCESS. Vielleicht hilft dir das auch weiter?! LG Jonas

Ich habe das gleiche Problem. 


Die Bestellungen kommen korrekt in Billbee an. 

Wenn der Status von mir dann aber in Billbee manuell auf "Bezahlt" und/oder "Versendet" gesetzt wird, dann gibt es keinen Sync zurück zu WooCommerce und dementsprechend wird auch die "Bezahlt und Produkt versendet" Mail in WooCommerce nicht getriggert. 

Meine Shop Einstellungen sind ident zum Screenshot vom vorherigen Post. 


Könnt ihr hier bitte nochmal helfen?


Anmelden um einen Kommentar zu veröffentlichen